Ver4.9.1c#
- 主要功能
- 某些 Windows 环境下无法显示帮助。
- 命令
- [绘制(Paint)] 支持对称编辑。
- 文件输入/输出
- 支持导入 USD/USDZ 文件。(不含 Windows 32 位版本。)
- 问题修复
- 在 [骨骼] 中导入权重时,如果对象较多,选择区域会超出屏幕。
- [骨骼] 中 VRM 弹簧骨骼的刚度无法设置为大于 1。
- VRM 输入/输出会反转 VRM 0.x 碰撞体的 Z 坐标。
Ver4.9.1b#
- 主要功能
- 新增对 macOS 27 的支持。
- macOS 上的帮助内容现在会高亮显示与搜索关键字匹配的部分。
- 命令
- 在 [骨骼] 中配置蒙皮时,可以启用自动平滑权重。
- 即使没有对称顶点,[骨骼] 的 [镜像复制] 也可以通过插值设置权重。
- 提高了 [骨骼] 中 [转录(Transcript)] 的精度。
- 使用 [骨骼] 的 [复制 > 导出/导入] 时,可调整权重应用位置以匹配骨架。(* 仅适用于新保存的数据。)
- [绘制] 可以在跨越 UV 边界的面上进行自然的三维绘制。
- 扩充了 [绘制] 中可用的画笔类型。
- Python 脚本
- Python 已更新至 3.13 系列。
- 默认编码改为 UTF-8,并可在必要时指定编码重新载入数据。
- 问题修复
- 使用骨骼 [绘制 > 笔刷] 并以多色显示权重时,绘制过程中的颜色可能异常。
- 通过 SDK 调用 MQBoneManager::SetLink() 时,无法解除源骨骼关联。
Ver4.9.1a#
- 导入/导出
- FBX 导出支持嵌入纹理文件。
- 支持 WebP 和 JPEG XL 图像。(JPEG XL 仅支持 64 位 Windows。)
- 问题修复
- [材质 > 笔刷] 会编辑到隐藏的面。
- [厚度着色(Colorize thickness)] 会为未使用的材质启用顶点颜色。
- 对象或材质名称包含特定字符时,DAE 文件无法正确导出。
Ver4.9.1#
- 问题修复
- 在 [局部(Local)] 中缩放后,[法线(Normals)] 中的固定法线显示异常。
- [顶点颜色] 中的 [从纹理转换(Convert from texture)] 对 RGB 图像的转换结果不正确。
- macOS 版可执行文件缺少 ARM 架构。
Ver4.9.0f#
- 问题修复
- 启用 [CObj] 选项时,[适合视图(Fit to view)] 可能导致视野异常。
Ver4.9.0e#
- 问题修复
- 对象平滑的 [角度与面积(Angle and Area)] 选项无法正常工作。
- 拖动过程中按键,可能意外触发快捷键。
- 使用 [旋转] 命令将手柄吸附到顶点后,旋转时手柄中心会偏移。
Ver4.9.0d#
- 命令
- [旋转] 命令支持将手柄方向对齐到法线或边的方向。
- 预览
- macOS 默认渲染器改为 Metal,并支持正确显示透明效果。
- 导入/导出
- VRM 1.0 导入/导出支持自定义面部变形预设。
- 问题修复
- macOS 使用 Retina 显示器时,局部显示可能异常。
- 切换材质着色器时,纹理颜色可能异常。
- 部分功能不支持交换鼠标主键和次键。
Ver4.9.0c#
- 主要功能
- 环境贴图可使用 16 位 HDR PNG 图像。(仅限 BT.2020-PQ/HLG。)
- 命令
- 在 [UV 编辑] 中修改 UV 通道名称时,可同时修改所有对象和材质中的名称。
- [路径克隆(Path clone)] 支持导入线条并转换为对象。
- [路径克隆] 可在保持预览开启的同时执行各种操作。
- [路径克隆] 可通过指定外径、内径和分段数创建管道。
- [骨骼] 的 VRM 验证可以检查人形骨骼的父子关系。
- 预览
- glTF/VRM 着色器会在线性空间中对各纹理插值后显示。
- 导入/导出
- 导入 VRM 时,指定为人形骨骼的节点现在始终会注册为骨骼。
- 问题修复
- 扫描线渲染可能导致异常退出。
- 将映射投影从 UV 切换为其他方式后撤销,UV 坐标不会恢复。
- 使用多 UV 时,撤销会修改到与原来不同的 UV 通道坐标。
Ver4.9.0b#
- 面板
- 材质 glTF 着色器的扩展设置新增 [色散(Dispersion)]。(* 渲染尚不支持。)
- 命令
- [选择 > 笔刷选择] 可以直接输入直径数值。
- [骨骼] 支持拖放条目,以调整顺序或指定父级。
- [骨骼] 的骨骼列表新增更改层级的按钮。
- [骨骼] 的 VRM 碰撞体支持平面碰撞体和内部碰撞体。
- 问题修复
- [填洞(Hole)] 填补包含线条的区域时可能崩溃。
- 扫描线或光线追踪渲染中,glTF 着色器的颜色不准确。
- 路径追踪渲染完成时可能意外崩溃。
- 导出 glTF 时,如果变形目标的顶点数/面数不同,程序可能崩溃。
- 导出 FBX 时,如果 UV 通道名称含有无效字符,程序可能崩溃。
- AMD Radeon 上的 OpenGL 显示发生错误。
- macOS 中为 glTF 着色器启用各向异性时,会显示错误消息。
Ver4.9.0a#
- 问题修复
- 打开灯光设置时崩溃。
Ver4.9.0#
- 主要功能
- 免费使用时,也可以使用相当于 Standard 版的功能。
- 问题修复
- [UV 编辑] 的 [对称中心] 菜单中,[使用选择中心] 无法工作。
Ver4.8.7c#
- 问题修复
- Direct3D 11 显示可能报错或卡死。
Ver4.8.7b#
- 命令
- [骨骼] 中的 [转换为 VRM 1.0] 现在也可以转换 MToon 着色器的颜色空间。
- 预览
- 取消 [阴影(Shadow)] 显示,改为提供 [遮蔽(Occlusion)] 显示。(仅支持 Direct3D 11,不支持 OpenGL/macOS。)
- 在 VRM 1.0 模式下,VRM 着色器使用 sRGB 颜色空间显示。
- 问题修复
- VRM 播放器中,采用初始值的 MToon 参数,其显示效果与设置值不一致。
- Direct3D 11 显示中,使用 glTF/VRM 着色器的半透明对象过于透明。
Ver4.8.7a#
- 面板
- 材质设置中,只有开启相应的 glTF 着色器扩展后,才显示对应的扩展参数。
- 预览
- 调整 VRM 着色器屏幕轮廓线的显示宽度,使其与其他查看器一致。
- 命令
- [UV 编辑] 的 [对称中心] 菜单可以直接输入中心坐标与对称轴。
- 导入/导出
- 文件浏览器现在会显示 VRM 文件缩略图。
- 导入 glTF/VRM 时,可以 [应用绑定姿势(Apply bind pose)]。
- 提高 VRM 导出与 UniVRM 的兼容性。
- 问题修复
- 材质设置中的 UV 坐标变换无法撤销。
- 注册为环境贴图的 HDR 文件颜色异常。
- Direct3D 11 显示中,glTF 着色器的反射颜色贴图和各向异性贴图显示不正确。
- OpenGL 透视投影显示中,PMD/VRM 着色器的轮廓线不显示。
- OpenGL 显示可能浪费内存。
- 没有弹簧骨骼时,[骨骼] 的 VRM 播放器无法正常工作。
- 即使在 VRM 输入/输出中指定缩放比例,也不会反映到世界坐标中的轮廓线宽度。
Ver4.8.7#
- 面板
- 材质设置支持 UV 坐标变换。(仅适用于 glTF/VRM 着色器。)
- 预览
- 可为每个视图选择 [启用]、[禁用轮廓线] 或 [禁用],指定是否应用着色器。
- 提升 PMD/VRM 着色器轮廓线的显示质量。
- 命令
- [骨骼] 的 VRM 播放器支持通过 VRMA 文件播放动画。
- [骨骼] 中的 VRM 人形骨骼名称已翻译为日语。
- [变形(Morph)] 支持法线、UV 坐标和顶点颜色的变形。
- [变形] 的 [预设设置] 中可设置 VRM 的材质颜色和 UV 坐标变换。
- [变形] 支持将目标 [自动注册] 到预设。
- 导入/导出
- glTF/VRM 输入/输出支持 UV 坐标变换(KHR_texture_transform),以及 UV 坐标和顶点颜色变形。
- 问题修复
- OpenGL 显示中使用多 UV 会发生错误。
- glTF 导出时,局部坐标输出不正确。
- 撤销时会丢失部分 VRM 信息。
- VRM 0.x 导出启用前后反转时,LookAt 的偏移量也被反转。
- PMD 导出即使设置为不输出隐藏对象,仍会输出变形目标。
Ver4.8.6e#
- 命令
- [骨骼] 的 VRM 播放器支持选择拖动目标(Root/Hips/LookAt)、循环播放、设置弹簧骨骼中心及眼球运动范围。
- [骨骼] 可合并多个弹簧骨骼(仅限 0.x),或批量设置多个弹簧骨骼的中心骨骼。
- 预览
- 调整 PMD 着色器轮廓线的显示宽度。
- 问题修复
- 删除弹簧骨骼时,其他弹簧骨骼的碰撞体可能消失。
Ver4.8.6d#
- 渲染
- 显示 [渲染] 区域时,视图中渲染范围以外的部分会变暗。
- 显示 [渲染] 区域时,视图中渲染范围以外的部分会变暗。
- 导入/导出
- 导入 VRM 时,可在浏览器中打开并查看元信息中的 URL。
- 导出 VRM 0.x 时,可以反转前方方向。
- 命令
- 增强 [骨骼] 命令的 VRM 编辑功能。
- 显示 [验证 VRM] 结果时,可以继续执行其他操作。
- 可将弹簧骨骼结构从 0.x 转换为 1.0。
- 可重新配置 VRM 1.0 的弹簧骨骼。
- 可截取屏幕画面并设置为缩略图。
- 增强 [骨骼] 命令的 VRM 编辑功能。
- 问题修复
- 某些电脑环境下无法启动 VRM 播放器。
- VRM 导出使用 VRM 着色器且轮廓模式设为屏幕坐标时,外部查看器中的轮廓宽度不正确。
Ver4.8.6c#
- 命令
- 可在 [骨骼] 的 VRM 播放器中检查弹簧骨骼运动,同时编辑其参数。
- 问题修复
- PMD 输入/输出无法正确处理表情。
- 某些 macOS 版本中,对象面板的眼睛/钥匙图标难以点击。
- macOS 的 Python 脚本中,部分 Python 标准模块不可用。
Ver4.8.6b#
- 命令
- [骨骼] 支持配置 VRM 的各种设置。
- [变形] 支持注册预设,包括 VRM 表情。
- 导出
- FBX 导出不再输出对象中包含的独立点和边。
- 问题修复
- [倒角(Bevel)] 指定圆角时,角部会扭曲。
- 对象被隐藏时,[UV 编辑] 无法切换 UV 通道。
- 存在未使用的 UV 通道时,多 UV 可能显示错误。
- glTF/VRM 导入时,对象名称与变形名称重复可能导致对象丢失。
- glTF/VRM 导出时,如果蒙皮对象的局部坐标不在原点,导出结果不正确。
- VRM MToon 着色器预览没有反映双面显示设置。
Ver4.8.6aa#
- 问题修复
- macOS Sonoma 中使用某些功能保存文件时,更改文件类型会显示错误消息,导致无法保存。
Ver4.8.6a#
- 主要功能
- 初步支持 macOS Sonoma。
- 预览
- PMD/VRM 1.0 着色器支持显示轮廓线。
- 问题修复
- [晶格(Lattice)] 命令的 [基准(Base)] 模式显示错误提示文字。
- glTF 着色器的虹彩厚度使用了错误的通道。
- VRM 导入器无法正确读取部分 MToon 参数。
- macOS 上无法显示对象设置等帮助页面。
Ver4.8.6#
- 命令
- [RenderMan] 集成不再作为标准功能提供,改为外部插件。
- 面板
- 材质面板的着色器新增 [VRM 1.0 MToon]。
- glTF 着色器扩展新增 [各向异性(Anisotropy)]。(* 渲染尚不支持。)
- macOS 上无法显示对象设置等帮助页面。
- 导入/导出
- glTF 导出新增变形的 [仅差异(Difference only)] 和 [网格压缩(Mesh compression)] 选项。
- 支持 VRM 文件输入/输出及 MToon 着色器。
- 导入没有对象名称的文件时,会根据文件名赋予对象名称。
- Python 脚本
- Python 版本改为 3.11 系列。
- 问题修复
- 纹理图像有时无法反映在材质设置预览中。
- OBJ 导入读取分组信息时,顶点会按面分离。
- Direct3D 显示中使用 Blinn 着色器会报错。
- 切换裁剪面的开关后,显示可能不正确。
- glTF 着色器显示中,顶点颜色没有与基本颜色相乘。
- [材质] 命令的 [分割(Segmentation)] 开启预览时,Shift+单击无法获取预览中的材质。
Ver4.8.5b#
- 命令
- [移动] 的 [法线方向(Normal vec.)] 模式中,关闭 [各个顶点(Each vertex)] 后,可沿三个坐标轴移动手柄。
- 导入/导出
- FBX 导入时,如果设置的 UV 通道不适用于映射图像,会重新指定默认 UV。
- 问题修复
- FBX 导出器输出的多 UV 坐标错误。
Ver4.8.5a#
- 导入/导出
- PLY 导入和导出支持面颜色。
- 问题修复
- 路径追踪渲染可能导致崩溃。
Ver4.8.5#
- 配置
- [视图] 的 [旋转操作(Rotation action)] 新增 [三轴轨迹球(3-axis trackball)]。
- 命令
- [材质] 新增 [笔刷] 和 [分割]。([分割] 仅限 EX。)
- [UV 编辑] 中,每个对象最多可指定四个 UV 通道。(仅限 EX。)
- [UV 编辑] 中,UV 展开图下方可切换显示纹理映射以外的图像。
- 面板
- 绘制面板可以显示和编辑非标准着色器专用的映射图像。
- 绘制面板中,如果 glTF 着色器映射图像只使用特定 RGBA 通道,就只显示那些通道。
- 渲染
- 降低路径追踪期间纹理的内存占用。
- 导入/导出
- FBX/glTF 导入/导出支持多个 UV 通道。(仅限 EX。)
- Python 脚本
- Python 版本改为 3.10 系列。
- 问题修复
- 文件极大时,无法保存 mqoz 文件。
- 光线追踪偶尔出现缺失像素。
- 路径追踪渲染时,间接光照可能导致渲染卡住,无法完成。
- 导出 .obj 时,对象的平滑角度未正确应用。
Ver4.8.4b#
- 主要功能
- 切换布局或重新启动后会保留视图分割位置,并可在菜单中重置。
- 记录视图信息时,可选择记录视角和编辑选项中的哪些内容。
- 导入/导出
- 可以将 .vrm 文件作为 glTF 载入。
- 问题修复
- 包含 Constant 着色器时,glTF 导出器可能输出错误数据。
Ver4.8.4a#
- 导入/导出
- glTF 导入器支持 sparse accessor(稀疏访问器)。
- 问题修复
- macOS/OpenGL 显示可能浪费内存并崩溃。
Ver4.8.4#
- 命令
- [选择 > 相连面] 支持限制选择角度。
- [移动] 新增 [固定方向(Fix direction)] 选项,使操作手柄方向保持不变。
- 未安装 RenderMan 时,隐藏 [RenderMan] 命令按钮。
- 面板
- [材质面板] 设置中,glTF 着色器扩展新增 [虹彩(Iridescence)]。
- 材质设置新增 [间接光照(Indirect Lighting)],可作为路径追踪中自身不可见的光源。
- 导入/导出
- glTF 导入/导出中,“meshes.extras.targetNames”现在对应变形对象的名称。
- 问题修复
- [局部] 中,即使启用 [CurObj],点击当前对象以外的对象仍会切换当前对象。
- [边 > 分割] 开启三角形拆分时可能卡死。
- [填洞] 填补包含线条的孔洞时,可能留下线条。
- [RenderMan] 降噪时,某些 RenderMan 版本可能显示警告。
- 根据 [显示单位] 的不同,在操作面板中旋转和缩放时,显示的角度及倍率可能不正确。
- 插入对象后撤销,有时会损坏骨骼。
- OpenGL 显示禁用 Alpha 混合时,对称平面也会显示为不透明。
- OpenGL 显示中,标尺或背景图像可能显示不正确。
- OpenGL 显示中使用 PxrSurface 着色器会报错。
Ver4.8.3b#
- 命令
- [骨骼] 的蒙皮绘制/复制模式中,可以使用移动、旋转和缩放快捷键。
- 导入/导出
- glTF 支持通过 KHR_materials_emissive_strength 扩展导入/导出大于 1 的自发光强度。
- 问题修复
- [倒角] 创建的顶点可能没有在各边之间共用。
- glTF 着色器的 [绒光(Sheen)] 显示不正确。
- glTF 着色器的法线贴图强度没有反映到路径追踪中。
- Windows 11 中,窗口最大化后边缘留有空隙。
- 关闭 [灯光方向/颜色] 后,显示没有更新。
Ver4.8.3a#
- 问题修复
- 如果将没有顶点的对象设为骨骼蒙皮,FBX 导出会崩溃。
- 路径追踪中,光源对象面积较小时,光照不准确。
- 某些 Mac 上,路径追踪启用降噪可能崩溃。
Ver4.8.3#
- 命令
- [测量(Measure)] 可沿径向测量 [厚度(Thickness)]。
- [测量] 中的厚度颜色显示可转为灰度或反相。
- 面板
- 材质属性中,glTF 着色器扩展新增 Ior(折射率)、Specular(高光)、Transmission(透射)和 Volume(体积)。
- 预览
- glTF 着色器扩展会应用到预览显示。(OpenGL 显示中,某些环境下部分纹理不会生效。)
- 问题修复
- [倒角] 生成的角部可能扭曲。
- 在对象面板中切换显示或锁定状态时,可能突然滚动。
- 对象的旋转体(Lathe)设置无法正确保存。
- 材质参数可能无法设置为大于 1。
Ver4.8.2a#
- 命令
- [边 > 分割] 中删除中间顶点支持对称编辑。
- 渲染
- 路径追踪可以准确渲染半透明部分。
- 导入/导出
- FBX 导入时,即使对象名称相同,也会作为独立对象处理,不再合并。
- FBX 导出支持法线向量变形。
- 问题修复
- 对象面板中拖动更改显示/锁定状态时,滚动行为可能异常。
- [边 > 分割] 在对称编辑中可能无法正确分割面。
- 路径追踪中,近处的面可能被裁剪。
Ver4.8.2#
- 命令
- [移动] 的 [法线方向] 可以沿每个顶点各自的法线方向移动。
- [边] 的 [分割] 可以按住 Alt(Windows)/option(macOS)单击,移除中间顶点。
- [顶点颜色] 支持 [转录(Transcript)]。
- [法线] 的 [转录] 可指定仅处理所选顶点还是全部顶点。
- [UV 编辑] 的 [转录] 可指定多个源对象。
- [UV 编辑] 可以重置 UV 视图。
- [骨骼] 的 [旋转] 新增 [旋转子级(Rotate children)] 模式,使子骨骼方向联动旋转。
- 渲染
- 路径追踪可设置 [散景(Bokeh)]。
- 导入/导出
- FBX 导出将没有顶点和面的对象输出为 Null 节点,而不是 Mesh 节点。
- FBX 导出可将 glTF 着色器转换为 Maya Stingray PBR 着色器。
- 问题修复
- 同时使用纹理映射和 Alpha 映射时,路径追踪可能崩溃。
- 对象尺寸极大时,路径追踪会出现条纹。
- 子面板跨越不同缩放比例的显示器时,切换命令会导致子面板偏移。
Ver4.8.1a#
- 主要功能
- macOS 启动后现在始终默认使用 OpenGL 渲染器。
- 问题修复
- 切换对象显示状态后,对某些操作进行撤销,可能无法恢复显示状态。
- [骨骼] 中输入旋转数值可能崩溃。
Ver4.8.1#
- 面板
- 可右键单击 [视图面板] 的 [记录] 按钮,记录或删除视图信息。
- [对象属性] 和 [材质属性] 新增按 Enter 键关闭窗口的设置。
- 在 [对象面板] 的 [克隆] 中创建对称对象时,局部坐标也会对称处理。
- [文档信息] 会显示骨骼数量。
- 命令
- [选择 > 笔刷] 新增选项:只要面的任意部分被笔刷覆盖,就选中该面。
- [挤出] 的角度可以设置为负值,以向外扩张的方向挤出。
- [骨骼] 的 [骨骼绑定] 中,[旋转] 可切换局部坐标和世界坐标来显示、输入旋转角度。
- [骨骼] 可以设置骨骼的前向轴。
- 问题修复
- macOS 上,部分窗口无法通过 Esc 键关闭。
- 包含此前从未显示过的环境贴图的 .mqoz 文件无法打开。
- FBX 导入时,骨骼方向可能与原始数据不同。
Ver4.8.0a#
- 问题修复
- 对象名称包含某些语言的字符时,.mqo 文件可能无法读取。
- 关闭 HDR 选项时,渲染结果导出失败。
- 自定义编辑模式中选择内嵌 [UV 编辑] 会崩溃。
- 撤销 [晶格] 变形可能崩溃。
- 部分着色器不显示背面区分颜色。
- 日语环境的 macOS 首次启动时,默认语言可能被设为英语。
Ver4.8.0#
- 主要功能
- [灯光] 属性可指定环境贴图。
- 更新安装时会沿用上次的安装位置。
- 面板
- [对象属性]、[材质属性]、[文档信息] 和 [渲染] 窗口打开时,可以执行其他操作。
- 移除 RenderMan 22 及更高版本不支持的旧 RenderMan 着色器。
- [材质属性] 新增用于路径追踪的 [透明(Transparent)] 着色器。
- [材质属性] 中,光照强度等参数可通过数值输入设为超出滑块范围的值,例如大于等于 1。
- [视图面板] 新增 [记录] 选项卡,功能相当于 F5–F8 键。
- 预览
- macOS 新增实验性 Metal 显示功能。
- 渲染
- 支持路径追踪(基于物理)渲染。(Standard 版限制渲染分辨率。)
- 最大渲染分辨率提高到 16384。(仅限 EX。)
- 渲染结果保存为 TIFF/HDR/EXR 时,可保存 32 位 HDR 图像。(仅限 EX。)
- 扫描线和光线追踪的纹理像素采样规则已调整,与预览显示完全一致。
- 菜单
- [平面化] 支持高质量平滑和滤波。(仅限 EX。)
- 取消 [导出到 DOGA-L 系列]。
- 命令
- [UV 编辑] 的 [移动] 支持按相对值移动 UV 坐标。
- [视图] 中的 [移动] 和 [旋转] 可通过按钮操作。
- 导入/导出
- F5–F8 键记录的视图信息会保存到 mqoz 文件中。
- 问题修复
- [骨骼 > 绘制 > 点] 启用 [Fr](正面)时,[Rc](矩形)和 [Rp](绳索)选择对面朝向的判断错误。
- 通过文件关联打开时,文件名包含特定字符可能导致无法载入。
Ver4.7.7d#
- 命令
- [RenderMan] 命令支持 RenderMan 24。
- 问题修复
- 使用 [法线] 命令时,固化镜像后法线显示异常。
- [法线] 中的 [转录] 可能工作不正确。
- 使用 [平面化] 的 [大范围平滑(Wide smoothing)] 时,预览不更新。
- 取消 [平面化] 等菜单操作后,预览仍然残留。(仅限 macOS。)
Ver4.7.7c#
- 命令
- [选择] 的 [扩展(Growing)] 范围可以直接输入数值。
- [晶格] 变形过程中可以输入坐标数值。
- [路径克隆] 克隆多个对象时,会为每个对象应用其局部坐标。
- [路径克隆] 可以输入控制点坐标数值。
- 问题修复
- [晶格] 撤销后继续操作可能崩溃。
- [法线] 中的 [转录] 可能工作不正确。
- [布尔运算] 可能产生孔洞。
Ver4.7.7b#
- 问题修复
- [切刀 > 挖洞] 可能崩溃。
- [创建文字] 会崩溃。(仅限 macOS。)
- glTF 导入器无法载入文件名包含多字节字符的文件。(仅限 Windows。)
Ver4.7.7a#
- 菜单
- [四边形化(Quadlangulate)] 和 [加厚(Thicken)] 支持对称编辑。
- [固化] 可以为旋转体指定单面或双面。
- 问题修复
- [弯曲] 和 [切变(Shear)] 的向上向量无法通过拖动移动。
- 调用 [偏移位置(Shift position)] 后,初始值没有立即应用到结果。
- Direct3D 11 显示中,glTF 着色器的法线贴图显示不正确。
Ver4.7.7#
- 面板
- 材质属性的 glTF 着色器新增高光—光泽度设置,以及清漆/绒光/透射扩展。(这些设置不应用到预览。)
- 菜单
- [选中部分] 中的各项功能支持对称编辑。
- [对齐顶点] 和 [平面化] 合并为 [顶点对齐/平面化],并新增直线化功能。
- [顶点对齐/平面化] 和 [偏移位置] 可在设置参数时确认结果。
- [网格平滑] 改为 [网格细分/平滑],并可指定是否启用平滑。
- 提高 [布尔运算] 的 [稳健(Robust)] 模式稳定性。
- [布尔运算] 的 [体素(Voxel)] 模式可指定最大三角形数量。
- [布尔运算] 新增 [仅选择交集(Only select intersection)] 模式。
- [布尔运算] 可同时处理多个对象。
- 命令
- [选择] 的 [相连面] 和 [扩展] 新增 [相同材质] 选项。
- [移动] 的数值输入支持局部坐标轴。
- [移动] 的手柄方向可以通过数值输入。
- [缩放] 和 [旋转] 在选择内容改变时可以保持中心位置。
- [局部] 可将基准位置改为所选部分的中心。
- [局部]、[晶格]、[映射] 和 [UV 编辑] 可通过切换 [编辑选项] 中的 L/W/S,改变手柄移动所用坐标轴。
- [切刀 > 锯切(Saw)] 取消快速和稳健模式,并可指定是否保留切割侧面。
- [弯曲] 和 [切变] 新增 [二维(2D)] 模式。
- 预览
- 停止支持 Direct3D 9。
- 导入/导出
- glTF 导入器支持 Draco 压缩数据。
- glTF 导入/导出支持高光—光泽度设置及扩展。
- 问题修复
- [选择] 的 [循环边] 和 [扩展] 中,选中不属于任何面的线时,颜色不会改变。
- 在 [缩放] 属性中输入数值缩放时,即使启用编辑选项的 L,也会沿不同于局部坐标的轴缩放。
- 透视视图中,[切刀]、[边] 等命令的实际处理位置与边上的高亮位置不同。
- 特定条件下,[合并选中的相邻面] 无法执行。
- 使用 [骨骼] 时,[粘贴] 可能崩溃。
- FBX 导出时,非本地语言的对象名称会乱码。
Ver4.7.6#
- 主要功能
- macOS 版本原生支持 Apple Silicon。
- 鼠标指针尺寸会根据显示器 DPI(显示缩放)自动调整。
- Python 脚本
- Python 版本更新为 3.9.1。
- 导入/导出
- 多个格式的导入/导出新增 [恢复默认] 功能。
- 问题修复
- 在材质属性中按 Esc 键可能崩溃。
- [法线] 的 [转录] 可能无法将法线向量传递到同一位置的面。
- FBX 导出时,带旋转限制的骨骼,其旋转角度输出不正确。
- 对象名称或纹理文件名包含特定字符时,无法导入或导出 .3MF 文件。
Ver4.7.5a#
- 问题修复
- 某些条件下,[左视图] 的网格显示不正确。
- 特定条件下,Direct3D 11 视图显示“内存不足”。
- 选中对称骨骼时,使用 [骨骼 > 骨骼绑定 > 旋转 > 调整方向] 会崩溃。
- [骨骼] 中修改对称骨骼的旋转限制时,最小值与最大值会颠倒。
- macOS 上某些条件下,[骨骼] 的 [蒙皮设置] 中对象名称乱码。
- macOS 保存的 .mqoz 文件缩略图损坏。
Ver4.7.5#
- 主要功能
- 初步支持 macOS Big Sur。
- 导入/导出
- glTF 导入器支持法线向量。
- FBX/OBJ 导出新增 [三角形化] 选项。
- 问题修复
- macOS 10.15 中,[渲染] 保存时覆盖已有文件会卡死。
- FBX 导出没有输出骨骼旋转限制。
Ver4.7.4d#
- 问题修复
- 部分环境中使用 Direct3D 11 会导致程序崩溃。
Ver4.7.4c#
- 渲染
- 应用 PMD 着色器。
- 问题修复
- FBX 导入得到的法线向量可能错误。
- [骨骼] 中克隆的骨骼名称重复。
- [骨骼] 中固化得到的左右骨骼名称可能无效。
- Direct3D 11 中坐标轴可能显示异常。
- macOS 中,列表或树形列表不更新,或导致崩溃。
Ver4.7.4b#
- 问题修复
- 某些使用环境下,Direct3D 11 显示响应缓慢。
Ver4.7.4a#
- 导入/导出
- FBX 导入新增 [应用绑定姿势(Apply bind poses)] 选项。
- 问题修复
- 开启 [更改所选面中线条的颜色] 时,Direct3D 11 显示报错。
Ver4.7.4#
- 主要功能
- Windows 7/8 使用 Direct3D 11 需要安装 D3DCompiler_47.dll。
- 命令
- [骨骼] 新增 Unreal Engine 4 骨骼模板。
- 菜单
- [渲染] 的光线追踪支持 glTF 着色器。
- 导入/导出
- FBX SDK 更新至 Ver2020.0.1。
- FBX 导入时,物理材质(Maya Stingray/Arnold、3dsMax Physical/VRay)会指定为 glTF 着色器。
- 问题修复
- [减少多边形] 预览后取消会崩溃。
- 多个视图使用不同透明模式时,Direct3D 11 预览错误。
- 导入由 3dsMax 导出的 FBX 文件时,顶点有时位置错误。
Ver4.7.3#
- 命令
- [骨骼] 的 [对齐] 新增 [使两根骨骼对称]。
- [骨骼] 中拖动时右键合并骨骼,会继承两根骨骼的权重。
- 问题修复
- [文件浏览器] 中的文件未按名称排序。(仅限 macOS。)
- [渲染] 没有应用 [翻转法线贴图] 设置。
- [父子之间的中间骨骼] 会移动中间骨骼以外的骨骼。
- [骨骼列表] 中调整的顺序在重新载入后恢复原状。
- [骨骼] 在网格操作后重做会丢失权重。
- PMD 导出时,扭转骨骼设置被赋给了父骨骼。
Ver4.7.2b#
- 主要功能
- 界面会随 macOS 外观(浅色/深色)变化。
- macOS Catalina(10.15)的安全警告使安装过程复杂。
- 问题修复
- macOS Catalina(10.15)保存文件时,扩展名不会自动改变。
- 操作后列表和绘制面板不更新。(仅限 macOS。)
- 对象名称包含非英文字符时,程序会卡死。(仅限 macOS。)
- 帮助窗口停靠后,部分快捷键不可用。(仅限 macOS。)
Ver4.7.2a#
- 问题修复
- 导入和导出 FBX 文件时崩溃。(仅限 macOS。)
Ver4.7.2#
- 主要功能
- 支持的 macOS 版本改为 10.11 及以上。
- 命令
- [移动] 中拖动时,除了右键,也可按空格键合并顶点。
- [骨骼] 变形也会影响已锁定的对象。
- 克隆、合并、固化、粘贴等操作后,会传递 [骨骼] 权重。
- 导入/导出
- 支持 FBX 2020.0。(不含 Windows 32 位版本。)
- 问题修复
- [移动] 拖动时右键合并,会吸附到隐藏顶点。
- macOS 上检查更新始终失败。
Ver4.7.1#
- 菜单
- [减少多边形] 可以在完成前显示预览。
- [减少多边形] 的 [快速] 算法速度更快、精度更高。
- [UV 编辑 > 输出] 的最大输出分辨率提高到 16384。
- 命令
- [选择 > 路径(Root)] 新增沿折痕选择的选项。
- [背景图(BkImg)] 支持旋转背景图像。
- 导入/导出
- 载入 JPEG 图像时,会应用 EXIF 中的旋转信息。
- 问题修复
- [移动] 中拖动时右键合并,会合并到已选中的顶点。
- [挤出] 未启用编辑选项 [X/Y/Z] 时,结果会损坏。
- [法线] 中的 [平均] 有时会崩溃。
- 启用编辑选项 [W/L] 时,[法线] 不会将所选顶点的法线方向反映到输入栏。
- [变形] 选择对象列表中折叠的目标对象时会崩溃。
- glTF 导入的缩放倍率没有应用到局部坐标或骨骼。
- 未注册版本限制的提示消息乱码。(仅限 macOS。)
Ver4.7.0#
- 主要功能
- 首次启动软件时显示初学者指南。
- [材质属性] 可以指定纹理图像边界的处理方式。
- 增加对象和材质名称的字符数上限,最多支持 63 个 UTF-16 字符。
- 插件可以直接从 ZIP 文件安装。
- 命令
- [拉出] 可以通过数值指定宽度,创建矩形面。
- [弯曲] 和 [切变] 可以用数值指定变形量。
- 调整 [骨骼] 规格,以节点结构为基本格式,并改进参数和操作方式。
- PMD 设置模式中,骨骼列表可用日语显示骨骼名称。
- 对称复制时,可以设置镜像骨骼的命名规则。
- 新增骨骼对齐功能。
- [绘制] 命令新增基于姿势的动画播放。
- [绘制] 命令新增 [针(Needle)],用于绘制背面顶点的权重。
- [绘制] 命令可列出分配给所选顶点的权重。
- 导入/导出权重时,可同时处理多个所选对象。
- 预览
- 更改法线计算方式。未指定折痕时,也可以编辑双面多边形的法线。
- 改善 glTF 着色器的显示还原度。
- 修复三维视图中的网格和刻度间距有时过密的问题。
- 导入/导出
- 标准文件格式由 MQO/MQX 改为 MQOZ。
- OBJ 导入新增使用 UTF-8 编码读取的选项。
- glTF 导入/导出以及 DAE 导入支持骨骼和变形。
- 骨骼改为节点结构后,改善了 FBX 和 PMD 导入/导出的层级结构兼容性。
- [文件浏览器] 支持显示 3MF 和 DAE 文件缩略图。
- 取消 COB(trueSpace)、POV(POV-Ray)、WRL(VRML 1.0)、SUF(DoGA)、AMF 和 JMF(three.js)文件导出。
- 从文件插入对象时,支持导入骨骼和变形信息。(合并到已有同名对象的情况除外。)
- 问题修复
- [选择] 通过 [CurObj] 指定对象列表中折叠层级内的对象时,会出现问题。
- [渲染] 对设置了镜面反射的材质进行光线追踪时,耗时极长。
Ver4.6.9#
- 命令
- 新增 RenderMan 22 的着色器与光源参数。
- [RenderMan] 可以使用材质资源库。(RenderMan 21 及以上。)
- [RenderMan] 支持输出 RIB 文件。
- [RenderMan] 可以在后台渲染。
- [骨骼] 执行 [镜像复制]、[转录] 或 [导入] 时,可以仅应用到所选顶点。
- Python 脚本
- Python 版本改为 3.6.7。
- 问题修复
- 关闭窗口时,即使保存文件失败,软件仍会退出。
- 对称复制对象时,已编辑的法线没有对称处理。
- [法线] 中按住 Ctrl 键进行选择操作时,行为不正确。
- 编辑法线后,导出为某些非 mqo 格式时,会发生非预期的面分离。
- 使用 [局部] 命令移动对象时,已编辑法线变得不正确。
- [骨骼] 通过数值输入缩放时不起作用。
- [骨骼] 绘制权重时,顶点显示会短暂异常。
- [骨骼] 刚打开骨骼设置时,颜色不正确。
- 在 [材质设置] 中编辑 HLSL 着色器参数后,软件崩溃。
- Direct3D 11 显示中,glTF 着色器指定纹理后,基本颜色没有生效。
- OpenGL 显示中,指定 RenderMan 着色器的材质显示不正确。
- 部分 Python 脚本函数无法正常工作。
- Python 脚本报错时,指示错误位置的行号显示不正确。
- PMD 导出未设置骨骼组时,会输出错误数据。
- glTF 导入和导出无法正确处理层级与局部坐标。
Ver4.6.8#
- 主要功能
- 支持 macOS Mojave(10.14)。
- 命令
- [切刀 > 连续切割] 可以分割末端三角形。
- [RenderMan] 支持命令兼容 RenderMan Ver22。
- 问题修复
- [晶格] 中的手柄可能无法旋转。
- 对象仅包含线时,glTF 导出器会输出无效文件。
Ver4.6.7#
- 问题修复
- 导出 FBX 可能崩溃。
- Python 脚本中,部分设置用户数据的函数工作不正确。
Ver4.6.6#
- 命令
- [骨骼] 的 Humanoid 模板中,从胸部向上分出的骨骼改名为“UpperChest”。
- [骨骼] 的右键菜单拆分为 [断开与父级的连接] 和 [断开子级连接],并从骨骼设置中移除 [断开父级/子级]。
- 菜单
- [Voxeloid] 和 [纹理实体化(Solidify texture)] 可使用 [移动立方体(Marching cubes)] 算法,高速将体素转换为多边形。
- 面板
- [材质设置] 可以选择 glTF 着色器。
- 导入/导出
- PLY 导出可选择 [类型](点云、三角形、面)及 [导出法线向量]。
- 提高 OBJ 等格式导出包含大量对象和面的文件时的处理速度。
- 支持 glTF 导入和导出。
- 初步支持 LWO3(LightWave 3D 2018)格式导入。(部分着色器设置不会导入。)
- 问题修复
- 在对象列表中执行 [选择顶点/面] 时,软件可能崩溃。
- [骨骼] 对同一对象导出再导入权重时,权重值可能改变。
- [骨骼] 可能无法为球形锚点内的顶点分配权重。
- [骨骼] 执行 [复制] 或 [固化] 时,部分参数和父子关系没有正确复制。
- OpenGL 渲染器中,即使隐藏 [非当前对象的线],顶点仍会显示。
- Python 脚本中的 MQWidgetBase.width/height、MQDialog.close 等无法正常工作。
- Windows 中,首次运行后不会重新载入 Python 脚本路径。
- PMD 输入/输出中,模型或骨骼名称接近字符数上限时,可能无法正确处理。
Ver4.6.5#
- 问题修复
- [法线] 无法正常工作。
Ver4.6.4#
- 主要功能
- 即使多边形数量较多,预览显示等处理也已加速。
- 新增多个命令功能可注册为快捷键。
- 导入/导出
- 包含多个 UV 的 FBX 文件会选择更合适的 UV 通道。
- FBX 导出时,会尽量统一共用顶点的各面上的 UV 和顶点颜色。
- 问题修复
- [布尔运算] 使用 [快速] 模式时,不相交部分的面可能被删除。
- [脚本编辑器] 的替换功能可能工作不正确。
- 脚本编辑器中,py 文件名包含非英文字符时会报错。
Ver4.6.3#
- 配置
- 纹理图像最大分辨率提高到 16384。
- 命令
- [UV 编辑] 中,即使展开图与网格重叠,也能显示展开图。
- Python 脚本
- Python 版本改为 3.6.3。
- 问题修复
- 点击 [骨骼] 命令的 [应用变形] 时,软件可能崩溃。
- [变形] 将基础对象的修改同步到目标时,软件可能卡死。
- FBX 导出时,变形目标的输出顺序不固定。
- Windows 版无法将数字小键盘按键设置为快捷键。
- Mac 版在特定条件下使用曲面类型 1/2 时,软件可能崩溃。
- Mac 版 [UV 编辑] 的 [畸变] 显示选项不起作用。
- Mac 版 [自动展开] 的“适用于大量多边形”算法无法工作,可能导致崩溃。
- RenderMan 21 渲染将 [Trace] 设为 [Bidirectional] 时,会显示警告。
- Mac 版无法选择 RenderMan 21 的 [It]。
- Mac 版使用 RenderMan 降噪时,渲染结果错误。
Ver4.6.2#
- 命令
- [晶格] 恢复为像旧版本一样,可在修改过程中更改参数。
- [UV 编辑 > 晶格] 新增 [适合(Fit)]。
- [UV 编辑] 操作过程中的提示信息更易理解。
- [骨骼] 显示设置新增 [在其他命令中显示]。
- 问题修复
- 使用 [测量] 的周长功能时,软件可能崩溃。
- [统一面(Unify face)] 无法正常工作。
- 启用 [UV 编辑] 后,有时不显示展开图。
- [UV 编辑 > 自动展开] 无法识别此前“仅重新排布”的状态。
- 使用 Direct3D 11 时,UV 展开图中的背面可能不显示。
- PMD 或 RenderMan 着色器显示没有应用裁剪平面。
- OBJ/X 导出时,法线输出不正确。
- 欧洲字体的多行文本可能有部分显示被截断。
- macOS/OS X 的 [脚本编辑器] 可能工作异常。
Ver4.6.1#
- 问题修复
- 渲染器设为 OpenGL 时,不显示所选多边形的边。
- 渲染器设为 OpenGL 时,指定双面显示的材质不显示背面。
- [骨骼 > 绘制] 的 [模糊] 可能无法正常工作。
- 执行 [UV 编辑 > 缝合] 时,软件崩溃。
- [布尔运算] 使用体素算法时,带孔洞的对象可能被忽略。
- 保存 .mqo 文件可能崩溃。
- 64 位版本无法更改安装文件夹。
- macOS/OS X 版 [脚本编辑器] 的 [复制/粘贴] 或 [帮助] 无法工作。
- macOS/OS X 版的部分 Python 脚本无法正常工作。
Ver4.6.0#
- 主要功能
- 支持 Surface Dial 等设备的精细滚轮操作。
- 软件崩溃时自动保存 MQX 文件。
- 配置
- [文件] 的最近文件列表新增 [显示所有格式]。
- [自动备份] 新增 [最大大小] 设置。
- 鼠标操作新增配合 Shift 或 Ctrl 键的设置,并可从预设中选择。
- 工具面板中的脚本按钮可通过快捷键操作。
- 新增将自定义快捷键恢复默认的功能。
- 新增将全部设置(包括配置以外的设置)或部分配置恢复默认的功能。
- 菜单
- [平面化] 新增 [大范围平滑]。
- [布尔运算] 新增基于体素的算法。(Standard 版限制部分功能。)
- [Voxeloid] 和 [纹理实体化] 新增若干设置选项,并提高最终输出精度。
- 新增 [重建网格(Remesh)]。(仅限 EX。)
- 命令
- [切刀 > 连续切割] 可按指定分段数量分割面。
- [填洞] 的 [填补所有孔洞] 处理速度提升,并支持设置顶点颜色。
- [晶格] 和 [UV 编辑 > 晶格] 新增平滑插值选项。
- [顶点颜色 > 环境光遮蔽] 和 [测量 > 厚度 > 厚度着色] 处理速度提升。(仅限 EX。)
- [UV 编辑] 新增 [调整分组大小]。
- [UV 编辑] 的 [自动展开] 新增 [吸附选择] 和 [移除路径],便于添加和删除切缝。
- [UV 编辑] 的 [自动展开] 新增降噪等选项。
- [UV 编辑] 的 [自动展开] 新增“适用于大量多边形”的算法。
- [UV 编辑] 新增 [重新排布(Repacking)],根据编辑后的 UV 坐标重新排列映射图像。(仅限 EX。)
- [变形] 新增 [自动同步基础对象修改],将基础对象的修改自动反映到目标对象。
- 新增 [法线]。
- 预览
- 新增 [对称平面],在对称编辑时显示于三维视图。
- 新增 [裁剪平面]。移动裁剪平面可隐藏一侧的面,通过 [视图标题栏 > 显示 > 裁剪平面] 和 [视图 > 裁剪平面] 命令设置。
- Matcap 显示时,对象不再显示纹理图像。
- 加速 Windows/macOS/OS X 的 OpenGL 显示。
- 导入/导出
- [导出] 中的 [兼容 Ver2.2 的 MQO 文件] 改为 [带选项],可指定 [仅可见对象] 等选项。
- [导入] 支持带纹理映射数据的 PLY 文件。(仅限 EX。)
- [导入/导出] 支持 3MF 文件。(仅限 EX。)
- [导出] 和 [导入] 支持 FBX 2018.0。
- FBX/OBJ/PMD/X/POV/SUF/JS 导出,以及 FBX/OBJ/PMD 导入支持法线。
- JMF 导出选项新增 [反转纹理 V 坐标]。
- Python 脚本
- Python 更新至 3.6.1。
- macOS/OS X 版可以使用脚本编辑器。
- 问题修复
- 执行 [布尔运算] 的 [快速] 算法后,后续操作无法正常工作。
- 执行 [布尔运算] 的 [快速/稳健] 算法后,顶点颜色可能丢失。
- 对称编辑中使用 [边] 的 [交换] 时,顶点颜色或权重可能丢失。
- 对称编辑中使用 [边] 的 [交换] 时,顶点颜色或权重可能丢失。
- 渲染器设为 Direct3D 9 或 OpenGL 时,选中面的部分叠加显示会缺损。
- 渲染器设为 OpenGL 时,PMD 着色器显示偏暗。
Ver4.5.9#
- 命令
- [切刀 > 切割] 和 [布尔运算] 新增快速与稳健两种算法可选。
- Python 脚本
- 新增功能。
- 问题修复
- [切刀 > 切割] 和 [布尔运算] 处理面数较多的对象时失败。
- [绘制] 无法在五边形或更多边的多边形上绘制纹理。
- [骨骼] 中更改材质列表顺序时,材质面板显示错误。
- 更改骨骼父子关系时,软件可能崩溃。
- [骨骼] 的 Humanoid 模板存在一些错误。
- [对齐顶点] 上次使用局部坐标处理后,坐标值会不正确。
- 使用 [网格平滑] 后,多边形的 UV 和顶点颜色设置损坏。
- [文件浏览器] 内存不足时,显示错误消息后可能卡死。
- 对仅包含线或点云的对象应用 OpenSubdiv 曲面时,显示报错。
- macOS/OS X 版重新启动后,带 Control 键的快捷键设置丢失。
Ver4.5.8#
- 主要功能
- 调整数值输入栏,输入后不再减少显示的小数位数。
- 操作手柄的显示尺寸改为基本恒定。
- 菜单
- [对象 > 减少多边形 > 算法:指定数量] 处理速度提升,并且可取消。
- macOS/OS X 的 EX 版支持 [Voxeloid] 分辨率 256 及以上。
- 命令
- [测量] 支持在二维投影平面上测量长度和角度。
- [测量] 支持测量周长。
- [测量] 的 [长度] 和 [周长] 可以计算所围区域面积。
- 面板
- [对象面板] 的 [克隆] 支持沿局部坐标轴旋转或移动,创建克隆对象。
- 问题修复
- 恢复的面板尺寸与上次启动时不一致。
- macOS/OS X 版设置样条曲面 1/2 时,纹理显示扭曲。
- [晶格] 对称编辑时,撤销无法正常工作。
- [骨骼] 解除父子骨骼连接后,软件崩溃。
- [骨骼] 应用锚点时,锚点内部顶点可能没有分配权重。
- FBX 导出时,骨骼旋转角度限制输出不正确。
- FBX 导入/导出中,材质或纹理名称含有非字母数字字符时会乱码。
- SDK 执行 Compact 后,对象列表没有正确更新。
Ver4.5.7#
- 命令
- 提高 [骨骼] 的 [转录] 精度。
- [RenderMan] 支持命令可设置 [降噪(Denoise)] 选项。(RenderMan 20 及以上。)
- [RenderMan] 支持命令兼容 RenderMan Ver21。
- 导入/导出
- OBJ 导入支持分组信息。
- 问题修复
- [选择] 操作偶尔导致软件崩溃。
- [UV 编辑] 的 [自动展开] 设置 [按材质分组] 后,无法正常工作。
- 部分功能,例如 [挤出],数值没有反映显示单位设置。
- 导入 PMD 文件时,变形数据读取失败。
- 全屏模式下,窗口行为异常。(仅限 macOS/OS X。)
Ver4.5.6#
- 主要功能
- 改进四边形转三角形的划分,避免产生过小锐角。
- 命令
- [旋转] 的 [圆环(Rings)] 手柄旋转方向改为与鼠标拖动方向一致。
- [骨骼] 的 [骨骼列表] 可以设置为浮动窗口。
- [骨骼] 新增 [显示设置(Display config.)]。
- [骨骼] 可在 [骨骼设置] 中更改同一层级骨骼的顺序。
- [骨骼] 新增末端节点设置,用于没有长度的骨骼。
- [骨骼] 与 [变形] 的变形结果可在两个命令中相互显示。
- [骨骼] 的 [锚点] 新增 [封闭区域(Closed region)]。
- [变形] 中移动顶点支持对称编辑。
- 导入/导出
- 可从 FBX 格式导入骨骼数据。
- PMD 导出新增仅导出可见对象的选项。
- 问题修复
- 编辑对象后,[变形] 的目标设置出错。
- 使用 [双四元数] 时,移动父骨骼会导致末端骨骼异常变形。
- [骨骼] 的对称编辑不正确。
- 选择骨骼时,[骨骼列表] 显示不正确。
- [骨骼] 的 [蒙皮] 中将姿势重置为默认值时,软件崩溃。
Ver4.5.5#
- 问题修复
- [磁铁(Magnet)] 开启“仅选中的顶点”后,仍会移动非当前对象中未选中的顶点。
- FBX 导出启用“仅可见对象”时,如果存在不可见父对象,会崩溃。
Ver4.5.4#
- 菜单
- 可以从 [文件浏览器] 向当前文档插入对象。
- 执行 [加厚] 时保留 UV。
- 导入/导出
- FBX 导出可选择仅导出可见对象。
- Python 脚本
- 新增 material_per_object.py 脚本,为每个对象指定不同的材质。
- 问题修复
- [骨骼] 的镜像虚拟骨骼显示错误。
- [UV 编辑] 执行 [自动展开] 时,软件崩溃。
- 使用 [布尔运算] 或 [切刀 > 锯切] 时,软件崩溃。
- 扩展名包含大写字母的文件无法注册为 [Matcap] 预设。
- [材质设置] 中将文件拖入输入栏时,映射图像没有正确更改。
- 使用 [编辑面板] 移动或缩放对象时,不显示“撤销”标签。
- 渲染器选择 OpenGL 时,[UV 编辑] 的 UV 畸变显示为黑色。
- OBJ 导出分组信息时,如果存在没有面的对象,分组会错误。
- 特定条件下,导出 OBJ 文件会崩溃。
- 包含蒙版信息的 IFF 文件无法正确载入。
Ver4.5.3#
- 命令
- [骨骼] 处于蒙皮模式时,可对称移动或旋转骨骼。
- 勾选 [骨骼 > 蒙皮设置] 的 [影响骨骼数量上限] 后,骨骼数量限制会始终反映在显示中;[归一化权重] 也可以据此限制权重值。
- 导入/导出
- 即使数据量较大,OBJ 文件导出耗时也已缩短。
- FBX 导出时,会根据 [影响骨骼数量上限] 限制权重值。
- 问题修复
- [双面面片(Double sided face)] 会创建重复面。
- 启用 [对称编辑] 时,[边] 的 [添加] 会创建不对称的面。
- [UV 编辑] 中,非正方形纹理通过数值输入旋转时,图像纵横比会失真。
- 在 [骨骼] 的 [属性] 中更改父骨骼时,软件崩溃。
- [材质属性] 选择 PMD 着色器时,[高光] 的 [锐度(Power)] 范围不正确。
- [材质属性] 选择 PMD 着色器时,修改参数不会立即反映到预览。
- Direct3D 11 模式中,同时启用 [修正深度(Correct depth)] 和 [Matcap] 会崩溃。
- OpenGL 中切换视图布局后,不显示纹理。
- [绘制面板] 中部分 [效果] 无法正常工作。
- 导入 OBJ 时,名称含逗号的材质无法正确导入。
Ver4.5.2#
- 命令
- [骨骼列表] 显示 [节点] 时,旋转分叉源节点会同时旋转所有分支骨骼。
- [骨骼] 的 [数值输入] 修改 X/Y/Z 值后,可点击 [应用] 一次性应用。
- 问题修复
- [UV 编辑] 的 [纹理] 会显示与当前材质使用不同纹理的材质。
- [骨骼] 的 MMD 模板缺少 IK 组信息。
- 导出 SUF(ATR)文件时,纹理名称输出不正确。
- FBX 导出时,当前姿势输出不正确。
- PMD 导入后,虚拟骨骼无法移动或变形。
Ver4.5.1#
- 面板
- [对象属性] 中 OpenSubdiv 的 [UV 插值] 增加到六种类型。
- [对象属性] 中 OpenSubdiv 新增 [极限曲面(Limit surface)]。
- 命令
- [骨骼] 的 [属性] 可为 IK 骨骼设置 IK 父级。
- 载入 4.4 以前版本保存的 MQO 文件时,如果包含“center end”骨骼,其名称会转换为符合当前规则的末端名称。
- [RenderMan] 相机 [景深] 中的 [镜头直径] 和 [焦距] 改为 [光圈值(F-stop)]。
- 预览
- 加快 OpenSubdiv 曲面显示速度。
- 问题修复
- 保存文件后退出,仍会再次显示确认消息。
- 在 [视图] 中注册布局后,不显示新布局名称,而是显示原来的名称。
- [骨骼] 使用 [骨骼绑定] 或 [绘制] 时,对称编辑无法正常工作。
- [骨骼] 同时选择节点列表中的起点和末端节点时,多种编辑操作无法正常工作。
- [骨骼] 创建虚拟骨骼时,列表顺序会被改变。
- [骨骼] 使用笔刷编辑权重时,背面的权重也被更改。
- [渲染器] 选择 OpenGL 时,顶点颜色与 Direct3D 显示差异很大。
- 扫描线渲染中,多边形绘制不正确。
- RenderMan 20 中,[环境贴图] 和 [日光] 不显示背景。
- 导入 PMD 时,指定的 [大小] 没有应用。
- 导入 PMD 时,分组(显示面板)无法正确载入。
- 导入 SVG 时,复合路径的重叠部分无法正确读取。
Ver4.5.0#
- 配置
- 新增反转法线贴图方向的功能。
- 菜单
- 相同版本之间,无论 32 位还是 64 位,都可以复制粘贴面。
- 命令
- [填洞] 新增自动填补全部孔洞的功能。
- [权重] 移除 [确定] 按钮,滑块和输入栏的操作会立即生效。
- [骨骼] 的 [骨骼列表] 可切换为按骨骼或按节点显示。
- [骨骼] 可为每根骨骼设置 [浮动根节点(Float root node)] 和 PMD 格式参数。
- 改进 MMD 骨骼模板,新增眼睛骨骼和分组信息等。
- 新增 [变形(Morph)]。
- [UV 编辑] 的 [自动展开] 可指定旋转角度和间距。
- [UV 编辑] 完成 [自动展开] 后,对话框不再关闭。
- [UV 编辑] 的 [选择切缝] 中,[六面划分边界] 改为 [自动]。
- 提高 [骨架建模] 在小角度处分叉的精度。
- [骨架建模] 新增 [缩放] 和 [模板]。
- 取消 [骨架建模 > 宽度] 中 [等比例] 选项的使用限制。
- [骨架建模] 选择 [全部删除] 时,可指定对对象执行 [固化]。
- [骨架建模] 可为骨架指定材质。
- 新增 [RenderMan]。安装 RenderMan 后可直接使用它渲染,同时取消 RIB 文件导出。
- 面板
- [材质面板] 属性新增 RenderMan 着色器。
- 点击 [材质面板] 属性中的预览,可以设置预览形状。
- 预览
- Direct3D 11 显示支持以 [Matcap] 模式显示对象。
- 三个正交视图中,即使原点位于屏幕外,也会显示刻度。
- 导入/导出
- 导入文件时,可以选择新建还是合并对象与材质。
- 可以将 SVG 文件导入为线或面。(仅限 EX。)
- 支持读取 HDR(*)、OpenEXR(*)和 32 位浮点格式等图像。(* 仅限 EX。)
- 支持 PMD 文件导入。
- PMD 导出和 FBX 导入/导出支持输入、输出 [变形] 信息。
- FBX 导入/导出支持使用日语名称的对象和材质。
- FBX 导入/导出支持 FBX 2016.0。
- OBJ 导入/导出的 [反转映射 V 坐标] 默认设为反转。
- OBJ 导入支持顶点颜色信息。(* 非标准扩展规范。)
- Python 脚本
- Python 版本改为 3.4.3。
- 帮助显示在内置窗口中。
- 问题修复
- 视图宽度变得极小时,软件崩溃。
- 启用吸附时,生成面会导致软件崩溃。
- 取消 [UV 编辑] 的 [自动展开] 时,当时的处理结果仍被应用。
- [UV 编辑] 中不显示对象的边。
- [骨架建模] 使用手柄移动对象时,即使未开启对称编辑,对称点也会移动。
- [骨骼] 选择并编辑多根骨骼后,撤销会使软件卡死。
- 界面尺寸较大时,对象/材质面板的部分内容不可见。
- FBX 导出会为各对象重复生成同名材质。
- 复制已设置层级的对象时,子对象的局部坐标发生偏移。
- Direct3D 9 保存截图时,改变分辨率会破坏纵横比。
Ver.4.4.3#
- 命令
- [UV 编辑] 的 [缩放] 根据鼠标移动始终以固定比例缩放,不再受选择状态影响。
- [UV 编辑] 的 [移动] 中右键操作时,所选顶点始终吸附到距离鼠标指针最近的 UV 顶点。
- 问题修复
- 为 [显示(Disp)] 选项部分菜单分配的快捷键不起作用。
- 文件路径方式设为 [相对路径] 时,无法将其他磁盘上的文件指定为映射图像。
- [移动] 对来自多个对象的所选顶点进行吸附后,撤销无法正常工作。
- [UV 编辑] 的 [自动展开] 在较小目标范围内重新排列时不正确。
- 特定条件下,带平滑组导出 FBX 会崩溃。
- 改善 FBX 导出中法线向量和骨骼权重与其他软件的兼容性。
- 调用 [平面化] 后,预览没有立即更新。
- Python 脚本删除对象或材质时,软件可能崩溃。
Ver.4.4.2#
- 命令
- [UV 编辑] 可分别指定 UV 和三维视图的选择目标。
- [UV 编辑] 中 Ctrl+Shift+单击顶点选择整组时,如果顶点已选中,则会取消选择。
- [UV 编辑] 配置新增反转缩放/旋转 Alt 键行为的设置。
- 导出
- FBX 导出支持平滑组。
- 问题修复
- 使用 [UV 编辑 > 磁铁] 时,有时会移动其他对象的顶点。
- [UV 编辑 > 晶格] 中,手柄旁的文字有时不显示。
- [UV 编辑 > 自动展开] 使用 [仅重新排布] 时,相连分组的一部分有时会分离。
- [骨架建模] 同时选中两侧对称顶点时,顶点会朝错误方向移动。
- [骨骼] 的吸附无法正常工作。
- 使用 [平面化] 或部分插件修改后,预览不更新。
- [布尔运算] 在 Windows XP 上无法工作。
- 命令面板隐藏时,无法从工具面板调用各命令。
- 在材质面板中拖动调整条目顺序时,条目有时被插入错误位置。
- 修改材质设置时,[撤销] 不更新。
- 材质设置中,通过颜色指定的参数无法正常工作。
- 使用某些鼠标时,列表滚动不正常。
- 为 [显示(Disp)] 选项部分菜单分配的快捷键不起作用。
- 分配给 CapsLock 键的快捷键不起作用。
- Direct3D 11 渲染器中,线条的选择状态有时显示不正确。
- Windows XP 上文件关联失败。
Ver.4.4.1#
- 命令
- [UV 编辑] 的 [配置] 新增选项,可选择是否使用编辑选项。
- [UV 编辑] 导出展开图时,输出与当前显示状态一致的图像。
- 问题修复
- 翻转面时,各边的曲面权重发生互换。
- 将吸附菜单注册到工具面板后无法使用。
- 创建或复制对象时,[撤销] 被重复记录。
- 为映射图像指定无效文件名后,调用 [UV 编辑] 会崩溃。
- [UV 编辑] 的操作快捷键无法正常工作。
- [UV 编辑] 的 [拉直(Straighten)] 高亮显示不正确。
- 特定条件下,使用 [UV 编辑] 的 [自动展开] 会崩溃。
- [骨骼] 使用 [绘制] 或 [应用变形] 时,变形未应用。
- 发送到剪贴板的图像可能无法被其他软件接收。
Ver.4.4.0#
- 主要功能
- [灯光] 可以注册和调用灯光预设。
- 搜索帮助时,高亮显示与搜索结果匹配的文字。
- 配置
- 新增 [颜色映射],用于 [骨骼]、[测量] 和 UV 映射畸变的显示。
- 菜单
- [布尔运算] 可以处理多个面重叠的对象。
- 命令
- 大幅改进 [UV 编辑]。
- 各项操作可以编辑当前对象以外的对象。
- 统一 [选择]、[移动]、[旋转]、[缩放] 的操作,各项操作均可启用 [Rc] 和 [Rp]。
- [展开(Expand)] 可以处理面。
- 新增 [晶格]、[松弛]、[拆分]、[缝合]、[拉直]、[顶点滑动] 命令。
- 新增 [对称化]、[翻转 U]、[翻转 V]、[镜像复制]、[转录(*)] 和 [对称中心] 菜单。(* 仅限 EX。)
- [笔刷] 和 [磁铁] 不再受纹理纵横比影响,始终按圆形处理。
- [自动展开] 可选择算法(基于角度、LSCM、六方向、仅重新排布)和目标范围。
- [自动展开] 改为先选择切缝线,再执行展开。
- [自动展开] 可以固定部分所选顶点后再修改 UV。
- 对象上可以显示 UV 的 [切缝] 和 [畸变]。
- [对称编辑] 的目标改为具有对称面与对称 UV 的对象。
- [导出] 可以将展开图发送到剪贴板。
- 展开图下方可以显示透明度贴图。
- [骨骼(Bone)]
- 可为每根骨骼设置 [可见]、[锁定] 或 [镜像]。
- 骨骼可作为模板文件导出或导入。
- 骨骼姿势可导出到文件或从文件导入。
- [球体(Sphere)] 中可设置权重的强度与宽度。
- 使用 [球体] 设置权重时,可实时预览结果。
- 蒙皮模式下可显示使用镜像的对象。
- 提高 [顶点颜色] 的 [转换为纹理] 在面边界处的精度。
- 大幅改进 [UV 编辑]。
- 问题修复
- Windows 任务栏设为自动隐藏时,最大化窗口会将任务栏遮挡在窗口后方。
- [渲染] 的 [光线追踪] 对四边形面的插值与其他方式不同。
- [倒角] 在四条边围成的位置插入顶点时,顶点位置会偏移。
- [骨架建模] 的分支控制点方向相近时,网格会丢失。
- 某些情况下,导出 FBX 文件时软件崩溃。
- [移动] 中按住 Ctrl+Shift 显示旋转手柄时切换到其他命令,再返回移动命令,旋转手柄会一直保留。
Ver.4.3.4#
- 问题修复
- 打开 MQO 文件时,层级设置没有生效。
- 没有 UV 映射的镜像对象无法进行投影。
- 材质面板中设为 PMD 着色器后,[设为默认] 的参数显示无效。
- [晶格] 的手柄坐标轴从正面观察时不会隐藏,导致中央部分难以操作。
Ver.4.3.3#
- 主要功能
- 右键单击部分命令的子面板,可以打开快捷键设置菜单。
- 切换编辑模式后,如果当前命令在该模式中不存在,会选择之前的命令。
- 面板
- [材质] 的 [属性] 可以选择 PMD 着色器。
- 命令
- [移动] 勾选 [法线向量] 后选择线条时,操作手柄会沿线条方向显示。
- 导出
- 视图的 [裁剪范围(Clip Range)] 会保存到 MQO 文件。
- 导出 PMD 时,将具有多个法线方向的顶点分开输出,以保留平滑着色。
- 导出 PMD 时,可为不在 MMD 模板中的骨骼指定组名。
- Python 脚本
- Script 文件夹新增 select_open_edge.py,用于选择开放边、UV 边界或材质边界。
- 问题修复
- 打开使用 [骨骼] 等功能的文件后,可能无法操作或文件损坏。
- [骨骼 > 绘制 > 点] 选择多个顶点时,指定数值没有正确设置。
- [骨骼 > 蒙皮设置] 先设为 [双四元数] 再改回 [线性] 后,[蒙皮] 的 [缩放] 无法使用。
- 选中多根骨骼时,输入移动或旋转数值会导致崩溃。
- 骨骼尺寸较小时,对称编辑不起作用。
- 没有骨骼时,导出的 PMD 文件包含错误数据。
- 界面尺寸设为 [小] 时,[基本体] 等命令的操作手柄被输入框遮挡。
- [UV 编辑] 中即使按住 Shift 键,点击空白处仍会取消选择。
- [UV 编辑] 选择顶点模式下,展开图中鼠标下方的顶点不高亮。
- [雕刻] 的 [平滑] 会让顶点过度聚集到中心。
- [雕刻] 的 [自动细分] 生成的面没有指定材质。
- Direct3D 11 渲染器中,使用 [测量] 测厚后,滑块数值变化没有反映到显示。
- [Anguwrap] 无法展开几何形状对象的 UV。
- [渲染] 相机距离过远时,会出现黑色噪点。
- 多行文本输入栏中,Backspace 或 Delete 键无效。
Ver4.3.2#
- 面板
- 脚本编辑器支持 Python 语法高亮。
- 命令
- [权重] 可以设置显示颜色的范围。
- [骨骼] 支持拆分或合并选中的骨骼。
- [骨骼] 无需解除蒙皮设置,即可切换骨骼绑定和蒙皮模式。
- [骨骼] 支持双四元数变形。
- [骨骼] 可以显示每根骨骼权重值的颜色。
- [骨骼] 权重可对称复制、传递到其他对象,或从文件导入/导出到文件。
- [权重] 可以设置显示颜色的范围。
- 导出
- 保存带骨骼设置的文件时,MQX 文件体积减小。
- 导出 PMD 时,改善四边形划分方向的判断精度。
- 问题修复
- [UV 编辑] 开启对称编辑后,使用手柄移动 UV 顶点会影响其他顶点。
- [UV 编辑] 通过绳索或矩形选择 UV 顶点时,数值输入栏不更新。
- 显示多个视图时,[投影(Project)] 会作用到没有显示展开图的视图。
- [材质面板] 的 [保存到文件] 会保存错误文件。
- [材质面板] 执行 [克隆]、[删除] 或 [设置属性] 后,不显示纹理图像。
- 对象使用球面和 UV 以外的映射时,[光线追踪] 渲染会破坏映射效果。
- [骨骼] 的 BVH 模板中,右腿没有居中。
- SDK 的 GetEditOption() 未正确返回 SymmetryDistance。
Ver4.3.1#
- 问题修复
- [配置] 中部分颜色说明发生错位。
- 屏幕垂直分辨率较小时,[对象属性] 右端显示缺失。
- [透明(Alpha)] 启用 [修正深度] 后,[UV 编辑] 中半透明纹理上的展开图显示缺失。
- [UV 编辑] 的部分展开图与对象重叠。
- [UV 编辑] 对称移动 UV 顶点时,其他 UV 顶点会旋转。
- 启用 [闭合曲线] 和 [位于点上] 时,复制对象没有放到控制点位置。
- 即使没有使用骨骼,也始终创建 MQX 文件。
- 开启 [IK 末端节点] 时,导出的 PMD 文件部分损坏。
- 导出 PMD 时,同一位置具有不同 UV 的顶点被合并为只有一个 UV 的顶点。
Ver4.3.0#
- 主要功能
- 颜色设置新增 [十六进制(Hex)]。
- 文本和数值输入区域支持 Ctrl+Z 撤销。
- 配置
- 新增 [固定顶点] 的颜色设置。
- 菜单
- [文件浏览器] 中对象颜色较暗时,背景自动改为白色。
- [固定选中的顶点和面] 改为 [固定选中的顶点];选中面时,会固定该面的顶点。
- 命令
- [选择] 的 [相连面] 或 [扩展] 可以选择线条。
- [缩放] 或 [旋转] 的 [属性] 可将手柄中心移到重心位置。
- [磁铁] 可以同时移动多个对象的顶点。
- [拉出] 生成三角形时,会应用相邻面的材质。
- [局部] 可以同时移动多个对象。
- [映射] 中点击手柄可以输入数值。
- [权重] 会根据权重值为线和顶点着色。
- [UV 编辑] 属性新增 [对称 UV 距离]。
- 新增 [骨骼]。
- [骨架建模] 的中心线可发送到 [骨骼]。
- [路径克隆] 新增在每个点上放置复制对象的模式。
- 各命令子面板的按钮上显示快捷键。
- 面板
- 对象面板属性可指定 OpenSubdiv 的网格和 UV 插值方式。
- 对象面板或材质面板 [其他(Misc)] 中,[注册] 菜单旁的图标可将参数恢复到初始状态。
- 右键单击材质面板中映射图像的 [参照(Ref)] 按钮,可选择首先显示的文件夹。
- 视图面板的数值输入区域可输入旋转中心和相机位置。
- 导入/导出
- 载入文件过程中可以取消。
- 提高 MQO 文件保存微小坐标时的精度。
- RIB 导出支持相机和纹理。
- 支持 PMD 文件导出。
- FBX 导出支持骨骼。(仅限 EX。)
- 即使 PLY 文件只含顶点数据,也可以导入。(仅限 EX。)
- 预览
- 自动计算网格大小时,三个正交视图的全部范围都会显示网格和刻度。
- Python 脚本
- 脚本运行中可按 Ctrl+C 中断。
- 问题修复
- 某些电脑上视图中的文字显示不清晰。
- 命令面板隐藏时,各命令快捷键不起作用。
- [挤出] 没有将顶点权重复制到挤出生成的面。
- [UV 编辑] 的网格显示在对象前方。
- [UV 编辑] 的平面、圆柱或球面模式中,点击 [属性] 不显示对话框。
- 注册到工具面板的 [视图 > 透明(Alpha)] 或 [渲染器] 子菜单无法工作。
- 随插件信息保存的顶点唯一 ID 无法正确载入。
Ver4.2.5#
- 导入/导出
- 顶点和面较多时,STL 等格式的导入速度提高。
- 问题修复
- 对象没有面时,[合并选中的相邻三角形] 会显示错误消息。
- [平面化] 中的粗化和平整功能颠倒。
- 两条或更多线共用同一面时,[边] 有时会在另一条线上添加新边。
- [骨架建模] 的 [拖动时添加] 会错误地移动新增顶点。
- 灯光设置从颜色库选取颜色后,颜色没有应用。
- 存在多边形时,使用旧版导出插件导出文件会报错。
- 样条曲面类型 1/2 中,三角形的细分线框显示不正确。
- Direct3D 11 显示中,当线宽大于 1,靠近相机的线条显示不正确。
Ver4.2.4#
- 配置
- 字体设置可以选择 OpenType 字体。
- Ctrl+PageUp/PageDown 可以增加或减少显示的小数位数。
- 命令
- [路径克隆] 的 [线条扫掠(Line sweep)] 处理大量线条时速度提升。
- 问题修复
- 按键时会显示未分配该快捷键的菜单。
- [渲染] 的光线追踪中,最末端的面有时会消失。
- [挤出] 等部分命令中,[CurObj] 选项不起作用。
- 存在禁用插件时,按快捷键会报错。
- FBX 导出的法线方向异常。
Ver4.2.3#
- 命令
- [路径克隆] 的 [线条扫掠] 对闭合曲线会在终点和起点之间创建面。
- [骨架建模] 的各个模式可分配快捷键。
- FBX 导出的格式和版本会在下次导出时恢复。
- 编辑模式的 [自定义] 可指定控件列数。
- 编辑模式的 [自定义] 可以导入和导出文件。
- 面板
- 绘制面板新增 [撤销] 和 [重做],无需切回主窗口即可执行。
- 预览
- OpenGL 显示也支持在 .mqo 文件中嵌入缩略图,以及在 [截图并保存] 中调整图像尺寸。
- 问题修复
- 仅支持 Direct3D 10 的 GPU 选择 Direct3D 11 渲染器时,会显示错误消息。
- 某些系统中,[透明 > 修正深度] 选项无法正常工作。
- [填充线条围成的区域] 有时会卡死。
- 最大化右上视图以外的视图后,切换编辑模式会导致视图显示不正确。
- 针对第二视图的 [视图面板] 操作不起作用。
- 编辑模式 [自定义] 中的部分参数没有应用。
- 启用 [Fr] 显示选项时,[UV 编辑] 不显示反向的 UV 映射。
- 即使文件中包含多个对象的骨架建模数据,也只载入第一个对象的骨架。
- 大型 COLLADA(.dae)文件无法正常载入。
- 导入文件时,三个正交视图偶尔会出现异常。
Ver4.2.2#
- 问题修复
- 添加编辑模式后,即使已正常载入,仍会显示错误消息。
- 自发光参数没有正确保存到 .mqo 文件。
- 使用 OpenGL 渲染器时,保存带缩略图的 .mqo 文件可能崩溃。(此版本在 OpenGL 渲染器下不再保存缩略图。)
- [绘制面板] 菜单等位置的快捷键不起作用。
- [路径克隆] 启用 [线条扫掠] 时,如果对象含有面,可能崩溃。
Ver4.2.1#
- 问题修复
- 打开 [文件浏览器] 前,没有询问是否保存已修改的文件。
- [切刀] 中的 [挖洞] 有时会报错或卡死。
- 导出 .obj 等部分格式时会报错。
- 4.2 以前版本保存且使用 OpenSubdiv 曲面的文件,会因开启 [平滑三角形] 而变得与原形状不同。
Ver4.2.0#
- 主要功能
- [编辑模式] 可以自定义。
- 编辑选项的 [网格] 改为 [吸附],支持吸附到平面、顶点、线和面。
- 视图标题栏的标题菜单新增 [截图并保存]。
- 视图标题栏 [显示] 新增 [透明 > 修正深度]。(仅适用于 Direct3D 11。)
- 配置
- 新增平板电脑或触摸显示器的触控与手写笔设置。
- 新增 [嵌入缩略图]。
- 面板
- 对象面板属性中,OpenSubdiv 新增 [平滑三角形]。
- 材质面板属性的 [自发光]、[高光] 和 [环境光] 支持 RGB 颜色。
- 菜单
- 新增 [文件浏览器]。
- 新增 [平面化(Planation)]。
- 新增 [第二视图]。(仅限 EX。)
- 命令
- [旋转] 属性可以输入手柄方向。
- [创建] 新增 [始终吸附到面];启用该选项或 [吸附] 选项后,可将点放置在面上。
- [挤出] 命令或 [挤出面] 菜单支持内嵌挤出。
- [基本体]、[填洞]、[切刀 > 挖洞/连续切割/连续擦除] 和 [元球 > 旋转/删除/复制/属性] 支持对称编辑。(但切刀无法处理跨越对称中心的面。)
- [晶格] 中点击手柄后可以输入数值。
- [元球] 的各项操作支持操作手柄。
- [元球] 和 [映射] 的属性会展开在子面板内,不再另开窗口。
- [元球] 生成的面以平滑方式显示。
- [元球] 在多核 CPU 上显示更快。
- [UV 编辑] 的 [缩放] 和 [旋转] 模式支持数值输入。
- [骨架建模] 新增 [复制]。
- [骨架建模] 的 [宽度] 可分别调整各轴尺寸。(仅限 EX。)
- [路径克隆] 新增 [线条扫掠]。
- 导入/导出
- 3DS/FBX/DAE 导入和导出中的自发光、高光、环境光支持 RGB 颜色。
- FBX 导入/导出支持 OpenSubdiv 权重信息。
- FBX 导出支持选择版本。
- 新增 AMF 导出。(仅限 EX。)
- 新增 three.js 导出。
- Python 脚本
- Python 版本改为 3.3.5。
- 问题修复
- 主要功能
- 多边形的法线向量偶尔会翻转。
- 帮助中的关键词搜索有时会漏掉结果。
- 配置
- Direct3D 的抗锯齿设置切换后,需重新启动才生效。
- 面板
- 对象面板展开或折叠子级时,不保留滚动位置。
- 绘制面板在 32 位纹理的 Alpha 通道上使用笔刷后,会留下异常矩形。
- 菜单
- [适合视图] 不更新视图旋转中心。
- [合并邻近顶点] 有时会创建两次引用同一顶点的面。
- [关于插件] 中导入或导出插件的设置,在重新启动时没有应用。
- [创建文字] 没有为生成的面指定材质。
- 命令
- [旋转] 中面板与手柄的角度正负号相反。
- [倒角] 使用圆角时,会在相同位置创建分离的顶点。
- [晶格] 的基础晶格已旋转时,[适合] 无法正确贴合。
- 预览
- Direct3D 11 中取消选中所有线条后,显示不更新。
- Python 脚本
- MQMaterial 的 setColor 无法设置 MQColor 值。
- 主要功能
Ver4.1.3#
- 主要功能
- 从正交视图切换为透视视图时,保留缩放和相机距离。
- 面板
- 下次启动时恢复视图面板的显示状态。
- 视图面板可以设置正交视图的相机距离。
- 脚本编辑器支持多次撤销和重做。
- 问题修复
- 菜单
- [导出到 DOGA-L] 处理多边形时崩溃。
- 预览
- 配置中关闭 [更改所选面中线条的颜色] 时,Direct3D 11 显示有时崩溃。
- 菜单
Ver4.1.2#
- 主要功能
- Windows 8/8.1 支持平板电脑手写笔和触控操作。
- 问题修复
- 主要功能
- 主窗口位于副显示器时,菜单显示位置不正确。
- 命令
- 其他对象在同一位置存在顶点时,[边 > 添加] 无法添加新边。
- 菜单
- 未设置平滑的对象,在 [渲染] 的光线追踪中仍以平滑方式渲染。
- [合并邻近顶点] 会留下多余线条。
- 预览
- 即使关闭 [透明(Alpha)] 显示,DirectX 11 或 OpenGL 仍会应用 Alpha 值或 Alpha 映射。
- 导入/导出
- 载入 8 位彩色 .bmp 文件时崩溃。
- 主要功能
Ver4.1.1#
- 主要功能
- 菜单始终显示在其他窗口之上。
- 帮助与命令同步时,会显示插件命令(骨架建模、路径克隆)的帮助。
- 配置
- 更改 [语言] 时,界面字体可切换为该语言的默认字体。
- [界面尺寸] 新增 [自定义],可以精细调整大小。
- 新增 [自动 DPI 调整],根据 Windows DPI 设置和显示器 DPI 自动调整界面尺寸。
- 操作手柄编辑新增 [编辑时显示数值] 和 [在手柄上输入数值]。
- 菜单
- [另存为] 在已有文件名时,会以该名称作为初始文件名。
- 命令
- [选择] 的 [循环边] 选择方向更符合直觉。
- [局部] 中点击一个面时,该面所属对象会成为当前对象。
- [边] 的 [分割] 用于独立线时,只分割该线,不再创建新三角形。
- [顶点颜色] 的 [转换为纹理] 可仅输出所选对象、面和材质。
- 导入/导出
- 加快带顶点颜色或权重的 .mqo 文件保存速度。
- 支持载入部分 V4/V5 格式的 BMP 文件。
- Python 脚本
- 新增顶点权重属性、获取语言或资源字符串的函数及相关设置。
- 问题修复
- 命令
- [矩形选择(Rect)] 会选中相机后方内容。
- [局部] 中分配给移动/旋转/缩放的快捷键无法正常工作。
- 存在固定顶点时,[磁铁] 对称编辑会将顶点移动到错误位置。
- 撤销 [顶点颜色] 的 [着色] 或 [环境光遮蔽] 时,没有恢复顶点颜色状态。
- 右键为 [UV 编辑] 菜单注册快捷键时,菜单项初始状态未激活。
- 即使未使用菜单且 [UV 编辑] 命令未激活,分配给 [UV 编辑] 菜单的快捷键仍会执行。
- 菜单
- [配置] 中无法显示帮助。
- [纹理实体化] 无法使用相对路径。
- 部分在 Ver4.0 中能正确处理的数据,[布尔运算] 会生成错误结果。
- [合并邻近顶点] 偶尔可能崩溃。
- [渲染] 的光线追踪对法线贴图处理不正确。
- 导入/导出
- 文件路径包含非 ASCII 字符时,FBX 导入和导出失败。
- SDK
- 设置了侧倾角(bank)时,Get/SetGlobalDirectionalLightDirection 返回错误方向。
- 插件更改当前对象后,[移动] 等命令的手柄方向没有更新。
- 命令
Ver4.1.0#
- 主要功能
- 编辑控件可通过右键菜单进行复制和粘贴。
- 视图 [显示] 菜单新增 [强制显示背面] 和 [高亮开放边]。
- 下次启动时恢复上次的视图投影方式:透视或正交。
- X/Y/Z 和 Pt/Ln/Fc 按钮也可以在右键菜单中切换。
- 提高光线追踪、环境光遮蔽等处理速度。
- 载入未知扩展名的文件时,会尝试按 .mqo 格式读取。
- 面板
- [视图面板] 可以更改目标视图。
- 菜单
- [渲染] 的扫描线渲染器支持凹凸/法线映射。
- 新增 [四边形化]、[加厚]、[Voxeloid]、[纹理实体化] 和 [法线着色]。
- [减少多边形] 新增快速算法。
- [布尔运算] 可对相互包含或分离的形状正确执行差集、交集运算。
- 命令
- 编辑选项启用 [Rc] 或 [Rp] 时,[倒角] 命令可选择顶点。
- [边] 命令的 [交换] 可顺时针交换由四边形或更多边多边形共用的边。
- [切刀] 新增 [锯切],可用线或矩形将面分离到新对象中。
- [顶点颜色] 新增 [从纹理转换] 和 [转换为纹理]。
- [骨架建模(Armature)]
- 可在控制点之间插入新点。
- [拖动时添加] 选项可通过拖动,沿路径连续放置点。
- 也可以仅删除位于两点之间、而非分叉处的点。
- 新增 [扭转(Twist)],用于调整面的走向。
- 可通过 Shift 键或编辑选项 [Rc]/[Rp] 选择多个点,并一起移动。
- [旋转] 可以操作多个选中的点。
- 骨架建模数据按对象分别管理。
- [UV 编辑] 菜单也可以分配快捷键。
- 新增 [路径克隆(PathClone)]。
- Python 脚本
- Python 版本改为 3.3.3。
- 标准输出显示在日志中,可正常使用 print()。
- import 会搜索当前编辑脚本所在的文件夹。
- 可以创建对话框、按钮等控件。
- 错误消息更加详细。
- 问题修复
- 主要功能
- 外部程序修改图像文件后,纹理没有自动更新。
- 包含数千顶点的多边形会导致崩溃。
- DirectX 11 不显示仅设置了 Alpha 映射的效果。
- DirectX 11 中凹凸映射显示不正确。
- 同时指定顶点颜色和权重时,[复制] 会崩溃。
- Windows XP 中指定当前目录内的映射图像时,路径异常。
- 菜单
- [渲染] 的光线追踪无法正确处理法线贴图。
- [渲染] 的光线追踪不会生成背面面的阴影。
- 命令
- [UV 编辑] 的确定按钮不会立即更新视图。
- [UV 编辑] 的磁铁选项无法正确处理多边形。
- 面板
- [对象面板] 或 [材质面板] 的列表可能异常滚动。
- 按住 Alt 键点击对象面板中的显示或锁定图标时,对象也被选中。
- 材质面板从颜色库选择颜色后,球体预览不更新。
- 材质面板修改反射或折射时,球体预览异常。
- 载入带 Alpha 通道的纹理图像后,修改 Alpha 通道会崩溃。
- 在绘制面板的图像以外区域右键单击会崩溃。
- 更改屏幕分辨率后再次运行,编辑面板会出现在屏幕外。
- 插件
- 部分旧版导入/导出插件可能崩溃。
- Python 脚本
- messageBox/println 显示多字节字符时乱码。
- SDK
- Get/SetGlobalDirectionalLightDirection 返回错误方向。
- RedrawScene/RedrawAllScene 在 OnUpdateObjectList 等事件中不会刷新显示。
- MQSpinBox/MQDoubleSpinBox 的 SetFocus() 无法正常工作。
- 主要功能
Ver4.0.3#
- 问题修复
- 32 位版本无法使用新版插件。
- 显示绘制面板时,即使按钮已按下,笔刷和调色板窗口也不显示。
Ver4.0.2#
- 主要功能
- 按下 Alt 键后,可通过键盘操作选择菜单。
- 命令
- 在 [移动] 或 [磁铁] 中点击手柄输入数值时,也可以输入单位。
- [局部] 中点击手柄后可以输入数值。
- [删除]、[翻转] 和 [材质] 可以操作相连的面。
- [挤出] 后取消选中顶点和线。
- [边] 的 [分割] 模式新增 [三角形化] 选项。
- [骨架建模] 的 [移动] 模式中,点击控制点后显示操作手柄。
- [UV 编辑] 的按钮可以注册到工具面板。
- [UV 编辑] 配置新增 [使用菜单]。
- 菜单
- [圆角(Round)] 中输入数值后,会立即更新预览。
- 预览
- Catmull-Clark 或 OpenSubdiv 会对顶点颜色插值。
- 问题修复
- [渲染] 不绘制双面面的背面。
- 在绘制面板中右键单击时,红色值和蓝色值颠倒。
- 编辑工具面板按钮名称后,按钮无法工作。
- 下次启动时,工具面板的停靠尺寸没有恢复。
- 载入包含纹理的 .lwo 文件时崩溃。
- SDK
- 在 MQStationPlugin::Exit 中写入的设置没有生效。
- MQCommandPlugin::GetResourceCursor 未返回有效句柄。
- MQDialog::Message 系列函数未返回有效值。
- 更改局部坐标后,各命令的手柄方向没有更新。
- Python 脚本
- 选择 UV 的函数不起作用。
Ver4.0.1#
- 问题修复
- 在对象面板的显示/锁定图标上拖动时,改变了错误对象的状态。
- [布尔运算] 创建的新对象被插入到无效层级中。
- 缩放视图时,三个正交视图的部分显示缺失。
Ver4.0.0#
Metasequoia 4 的首个版本。